NumLock

Inte löst
Detta ämne innehåller 8 svar, har 3 deltagare, och uppdaterades senast av  tozon 1 månad, 2 veckor sedan.
Skapare
rjo44
Deltagare

I nr 2/2017 sidan 78 finns en beskrivning på hur man ser till att NumLock är aktivt vid uppstart. Tipset är inte helt nytt och jag har tidigare gjort den ändring som föreslås (+ på ytterligare några ställen i registret). Det fungerar visserligen vid omstart men inte vid uppstart! Lampan som visar att funktionen är aktiv tänds visserligen vid starten men den har slocknat när det är dags för inloggning och det är väl åtminstone inledningsvis man vill ha funktionen aktiv?!

Jag har en tre månader gammal PC och alla uppdateringar från MicroSoft är på plats.

 

För att vara helt säker på att Num Lock alltid gör som man vill (oavsett om den ska vara aktiv eller ej) måste man gå in i datorn BIOD/UEFI och ändra standardinställningen för den tangenten. Detta blir dock trassligare än det låter, framför allt för att de flesta datortillverkare har olika tangentbordskombinationer för att låta användare ta sig in i BIOS/UEFI. Vad som fungerar står på skärmen för ett kort ögonblick när datorn startar. Det kan bland annat kallas för Setup, BIOS, UEFI, Settings med mera, tillsammans med en tangentbordskombination som kan vara F2, Del eller något annat av en mängd olika varianter. Men inte ens detta är säkert att det löser ditt problem, för det är inte alla som tillverkare av moderkort som har lagt in den inställningen, och har de inte gjort det går det inte att ändra.

Men börja med att gå in i din dators BIOS/UEFI och leta efter en inställning som heter något med Num Lock. Om den finns där, då kan du ändra den till det beteende du vill att tangenten ska ha.


tozon
Deltagare

    Men är det inte lite korkat av MS att ändra på numlock funktionen i W10 nu när man använder numeriska för att logga in.

    Det har ju alltid funkat så att numlock är på på alla datorer jag haft, så man inte behöver gå in och göra ändringar när enn udatering av Windows kommit.

    Man måste ju gjort nån generalmiss i programmet som ställt till det och som man måste se till att fixa?

    ///T

    Det behöver inte vara Microsoft som ligger bakom det, det kan lika gärna vara tillverkaren av moderkortet, därav att det är bra att gå in i BIOS/UEFI och undersöka om den inställningen finns.

    Ett trick som sägs fungera, men som jag inte har testat själv, är att du startar Windows som vanligt. När du kommer till inloggningsskärmen trycker du på Num Lock så att den får den inställningen som du vill ha. Sedan använder du musen för att klicka på avstängningsknappen i nedre högra hörnet och väljer att starta om datorn. Om man gör på det här sättet ska datorn komma ihåg inställningen som Num Lock hade när du valde att starta om datorn. Jag har som sagt inte hunnit testa tricket själv, men det kan ju inte skada att försöka.


    tozon
    Deltagare

      Nej, det funkar INTE och borde kommit fram vid alla omstarter.

      Varför skulle det ändras permanent när man installerat W10?

      Jag har det på fem PC’n och två surfplattor, och är nog inte ensam om det!!??

      Skulle vara intressant att höra om ALLA har det eller bara vissa, för jag är inte ensam tydligen?

      Har dock inte provat tipsen där man går in i BIOS’et och ändrar, för det borde vara kvar som det har varit tidigare att den alltid startar i ”NumLock” läge om man stänger av i det.

      ///T

      Jag har inte det problemet, det är därför jag inte är helt säker på att det har med Windows att göra, i varje fall inte enbart Windows utan möjligtvis kombinationen Windows 10/moderkort.


      tozon
      Deltagare

        Sorry, men surfplattorna har ju inte numeriskt på så sätt som laptop med numeriskt, men alla våra PC’n och de kompisar som har installerat W10.

        För att beskriva helt rätt, så startar dom i numlock läge tills inloggningen kommer, då går dom ur numlock trots att man inte rört tangentbordet. Då måste man trycka på numlock för att kunna använda numeriska tangentbordet att logga in med. Irriterande, men det började direkt när första versionen av W10 installerades, på alla PC’na, fast det installerades vid olika tillfällen, tror tom att ena datorn installerades med W10 först med ”1607”.

        ///T

        Jag har grävt vidare i detta och hittat ett uttalande från en Microsoft-anställd som säger att det är en inställning i Windows som styr detta, men att den inställningen påverkas av datorn hårdvara vilket förklarar varför inte alla drabbas av detta. Via olika hänvisningar kors och tvärs kommer man fram till två tips för hur man kan försöka lösa problemet, och det ena har vi redan tagit upp.

        Det andra handlar om att göra ändringar i Systemregistret, så jag vill göra helt klart att detta utförs på egen risk och om det råder osäkerhet – gör det inte.

        1. Sök efter och starta RegEdit.

        2. Navigera till HKEY_USERS\.DEFAULT\Control Panel\Keyboard.

        3. Leta reda på InitialKeyboardIndicators, dubbelklicka på det och ändra det till 80000002.

        4. Klicka på OK av stäng RegEdit.

        Som sagt, varning utfärdad, men detta sägs kunna lösa problemet.


        tozon
        Deltagare

          Jag har inte vågat provat detta ännu, men det är samma tips från flera håll, så det menas nog rätt.

          Verkar dock som datorn är inställd på att starta med ”NumLock” på, men det ändras när skärmen före inloggningen kommer. På ena datorn räcker det med att trycka på ”något” så kommer inloggningen upp med numlock på, men på laptoppen (med numeriskt) måste man dessutom trycka på numlock efter (eller kommer inloggningen upp samtidigt som man trycker på numlock) som man har inloggningsskärmen framme.

          Verkar lite ologiskt, men har provat lite olika och numlock kommer inte upp av sig själv som alltid tidigare, före W10.

          ///T

          Du måste vara prenumerant för att skriva inlägg i forumet